关于SG11加密使用、安装配置说明教程 sg11加密组件安装步骤

本帖最后由 野微信网 于 2020-08-8 20:16 编辑

1、他是否需要扩展安装?

是的,这个必须安装,组件下载地址见你使用模块时出现错误提示里面的一个链接

2、安装方法

打开PHP.INI 将对应的扩展放到EXT目录中,以PHP5.6 TS为例

添加代码:

extension=ixed.5.6.win(Windows服务器的)linux服务器的:extension=ixed.5.6.lin(linux服务器的)

可根据自己存放扩展ixed的实际路径修改:extension=文件存放实际路径ixed.5.6.lin或win服务器的ixed.5.6.win这种表示!

举例:WDCP PHP5.6.2.9版本实例:extension=/www/wdlinux/apache_php-5.6.29/include/php/ext/ixed.5.6.lin

3、保存php.ini

重启下apache或者iis服务!
即可完成安装。

常见问题:

1、支持的PHP版本?

支持5.2-7.0版本(默认选择为PHP5.2将同时兼容:PHP5.2-5.6),也可单独选择支持版本,如需支持PHP7,请单独选择。

2、

如何判断是NTS还是TS(WINDOWS用户)看PHP所在目录中的文件名PHP5.DLL(是NTS)PHP5TS.DLL(是TS)

3、为什么操作了 还是提示没安装?

请确认按照上面的步骤操作完成且都正确,然后重启web服务,清除下浏览器缓存,重新登录微擎查看是否安装成功!

参与评论